вторник, 13 ноября 2012 г.

Gentoo + HPLIP = грабли

В процессе переустановки сервера CUPS вылезли грабли - категорически отказывался устанавливаться пропиетарный плагин, в процессе установки принтера с помощью hp-setup.

Суть грабель в том, что дистрибутив Gentoo перешол на ветку Python 3.x, а HPLIP все еще использует ветку 2.х.

Что делать:
1. Смотрим что у нас в системе с питоном:
# eselect python list
Available Python interpreters:
[1] python2.7
[2] python3.2 *
Тут мы видим, что в системе присутствует 2 ветки 2.7 и 3.2, по умолчанию используется 3.2. Чтобы установить нужный hplip плагин, нужно переключиться на ветку 2.7. Делаем:
# eselect python set 1
Проверяем, что получилось:
# eselect python list
Available Python interpreters:
[1] python2.7 *
[2] python3.2
Видим, что теперь активна ветка 2.7.
Запускаем hp-setup, теперь плагин встанет как надо. После установки принтера не забываем вернуть python в исходное состояние:
# eselect python set 2
 Так вот кратенько сегодня.
Всем успехов.

Комментариев нет:

Отправить комментарий